SERGIOIGLESIAS

Blog sobre Joomla

Para qué sirve y cómo funciona el Pre-Update Check de Joomla

Si estás interesado en migrar tu página web de Joomla 3 a Joomla 4 te presento un componente que te va resultar de mucho interés para este proceso.

Para qué sirve y cómo funciona el Pre-Update Check de #Joomla (migración a #Joomla4) - #MejorConJoomla Tuitéalo

Antes de continuar, te presento algunos de los artículos que tengo escritos sobre migración a Joomla 4:

Para seguir te diré que partiré de una instalación de Joomla 3 (en su última versión, 3.10.3) con datos de ejemplo para ver el comportamiento de esta extensión, Pre-Update Check.

También decirte que, en primer lugar, no hay ninguna extensión de terceros instalada por lo que el proceso de migración debería ir sin problemas.

Luego instalaré alguna gratuita que no esté preparada aún para Joomla 4 para ver los avisos que nos muestra.

Pero venga, vamos al lío.

Cómo migrar de Joomla 3 a Joomla 4

Aunque los pasos ya están explicados en el cuarto artículo de los que te he recomendado más arriba, te comento que tendrás que ir al componente de actualización de Joomla: Componentes > Actualización de Joomla.

Aquí veremos la siguiente información:

actualizacion joomla

Como puedes ver, el mensaje es que tenemos ya la última versión estable de la rama 3. Pero lo que queremos es migrar a Joomla 4, así que, tendrás que ir "Opciones" y seleccionar la opción de "Próximo Joomla" en el campo de "Servidor de actualizaciones".

opciones actualizacion

Con esto ya nos saltará el componente del que trata este artículo: Pre-Update Check

pre update check

Voy a explicarte a contuación lo que se ve en la captura anterior.

1/ Configuración requerida de PHP y base de datos

Si haces clic en donde pone "Más detalles" te aparecerá un listado de los parámetros requeridos para el correcto funcionamiento de Joomla 4:

configuracion requerida

En este caso el servidor donde está instalado cumple con todo.

Tienes que tener en cuenta que Joomla 4 ya no funciona en versiones de PHP por debajo de 7.2.5. Un detalle que tendrás que tener en cuenta en caso de que tu servidor no soporte estas versiones.

Recuerda que Joomla 4 funciona muy bien en PHP 8, por lo que si tu servidor soporta esta versión, adelante con ella.

En caso de que aparezca algún parámetro que no se cumpla en el servidor aparecerá reflejado en esta pantalla y será conveniente que lo resuelvas antes de hacer la migración.

2/ Configuración de PHP recomendada

Igual que antes, para ver más detalles, picha en el enlace correspondiente.

configuracion recomendada

Como puedes ver hay alguna alerta (por esto también el color naranja).

El servidor donde estoy haciendo las pruebas es local y por eso tiene esta configuración.

Realmente, no tiene por qué estar todo en verde para que funcione la migración, pero sí que es recomendable.

3/ Información de actualización no disponible

Si estás en un servidor medio decente no deberías tener problemas con los 2 apartados anteriores.

El que realmente es importante revisar con atención es éste último.

informacion actualizacion

Puedes ver que me aparece en rojo y, curiosamente, la extensión (recuerda que una extensión en Joomla puede ser un componente, módulo, plugin, fichero de idioma y plantilla) sobre la que no hay información de actualización es el paquete de idiomas del español.

En este caso tendríamos que comprobar en la web del desarrolldor si esto es así o no.

Es importante destacar que no todas las extensiones están preparadas para proporcionar esta información; así que, aunque muestre "alerta" hay que confirmar que esto es así.

Para este caso, no habría problema en realizar la migración ya que sí que hay compatibilidad del fichero de idioma en español para Joomla 4.

Te voy a mostrar de nuevo una captura de esta misma pantalla con una extensión de terceros instalada que no tiene soporte aún para Joomla 4 (iCagenda) para que veas lo que nos pone.

informacion actualizacion error

Como puedes observar, nos indicaque no información y nos muestra diferentes "posibles problemas" para que los chequees.

Incluso hay un botón de "Más información"(en color azul) en el que si pinchas, te dice qué puede estar pasando.

Instalo ahora otra extensión de terceros que sí está preparada para Joomla 4 (JCE Editor) y vuelvo a mostrarte la misma pantalla.

informacion actualizacion ok

Puedes ver ahora que esta extensión aparece en el apartado "verde" de "No se necesita actualización" puesto que no presenta problemas a la hora de la migración a Joomla 4.


Con todo esto, creo que queda demostrado el gran trabajo que se ha realizado en Joomla para facilitar el proceso de migración de Joomla 3 a Joomla 4 para que no se nos escape nada.

Espero que este artículo te ayude en la migración. Sino, ya sabes que puedes contactar conmigo para cualquier duda/problema.

Y si quieres ayudar a otros usuarios... comparte el artículo ;-)

Para qué sirve y cómo funciona el Pre-Update Check de #Joomla (migración a #Joomla4) - #MejorConJoomla Tuitéalo

¿Te ha gustado el artículo?

Suscríbete a mi newsletter y recibe contenido exclusivo.
Podrás hacer gratis un Curso de desarrollo de plantillas Joomla.

Un comentario

  1. Lunes, 22 Noviembre 2021 21:52
    Articulo Ya gran ayuda. Gracias Sergio por tu valorable aporte.

Artículos relacionados

Solicita presupuesto

¿Quieres una página web que funcione?

Contacta conmigo y hablemos de tu proyecto.